motoring|underground  
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read Blog

Cornering Optimizing your suspension system.

Go Back   motoring|underground > On the Lifts > Cornering
Reply
 
Thread Tools
  #1  
Old 08-25-2008, 03:53 PM
simplygriff's Avatar
simplygriff simplygriff is offline
μ
 
Join Date: Nov 2005
Location: Greensboro, North ByGod Carolina
Posts: 14,863
Unhappy New Suspension... Really Harsh Ratttling

So I got my new suspension installed with HPUDrew's extensive help. We put in KW v1 coilovers, TSW Front Camber Plates and H-Sport Rear Control Arms. We bumped the H-Sport Comp. rear sway bar, that was already on the car, up to the middle setting from the softest. We also rotated the tires. My rear tires were wearing more on the inside but are now on the front of the car.

If feels good driving but when driving or going over a bump it feels and sounds like the front end suspension is gonna fall apart. More so at low speeds, but at virtually any bump in the road. It sounds like the whole camber plate and shock are wobbling around all jelly like. We torqued everything down according to the TSW instructions and everything I can visibly see or get to is definitely tight. Anyone got any ideas? Could we forget a washer or something? We used the top nut from the KW's instead of using the TSW one cause it was a beefier, locking nut. Could that have something to do with it? I'm gonna go have it looked at by the wonderful guys at Grassroots Garage as soon as I can but didn't know if anyone had any other ideas of things I can check on. I plan to take it to get the alignment as soon as I get this stuff figured out.
-G
__________________
phone is ringing . oh my god
Click the image to open in full size.
| The UnDedDub
Reply With Quote
  #2  
Old 08-25-2008, 03:57 PM
iDiaz's Avatar
iDiaz iDiaz is offline
μ
 
Join Date: Nov 2005
Location: San Marcos, CA
Posts: 15,878
Send a message via AIM to iDiaz
Default

Hm... and it's making a rattling sound while it knocks around? What sort of suspension did you have before? The jello-like feel kind'a sounds like shot front control arm bushings, but they'd have to be pretty trashed to make rattling noises.
__________________
Click the image to open in full size.
Reply With Quote
  #3  
Old 08-25-2008, 03:59 PM
simplygriff's Avatar
simplygriff simplygriff is offline
μ
 
Join Date: Nov 2005
Location: Greensboro, North ByGod Carolina
Posts: 14,863
Default

Went from H-Sport Springs and stock shocks. Stock shocks had ~35K miles on them.
-G
__________________
phone is ringing . oh my god
Click the image to open in full size.
| The UnDedDub
Reply With Quote
  #4  
Old 08-25-2008, 04:08 PM
iDiaz's Avatar
iDiaz iDiaz is offline
μ
 
Join Date: Nov 2005
Location: San Marcos, CA
Posts: 15,878
Send a message via AIM to iDiaz
Default

And there was no indication of a problem before you swapped to the new setup? No wobbly feel around corners? No clunking sounds?
__________________
Click the image to open in full size.
Reply With Quote
  #5  
Old 08-25-2008, 04:27 PM
simplygriff's Avatar
simplygriff simplygriff is offline
μ
 
Join Date: Nov 2005
Location: Greensboro, North ByGod Carolina
Posts: 14,863
Default

None at all. The bumps were harsher before (feels better now) but there was no clunking or rattling. I wouldn't say there's clunking now, just horrible rattling. I haven't driven it today though.
-G
__________________
phone is ringing . oh my god
Click the image to open in full size.
| The UnDedDub
Reply With Quote
  #6  
Old 08-25-2008, 04:29 PM
iDiaz's Avatar
iDiaz iDiaz is offline
μ
 
Join Date: Nov 2005
Location: San Marcos, CA
Posts: 15,878
Send a message via AIM to iDiaz
Default

Hm... the two main things I'd check are the nut that attaches the strut to the bearing in the camber plate and the swaybar end-links.
__________________
Click the image to open in full size.
Reply With Quote
  #7  
Old 08-25-2008, 04:36 PM
Drew Drew is offline
μ
 
Join Date: Dec 2006
Location: Winston-Salem, NC
Posts: 7,157
Default

It's because you had an amatuer leading your install, hahaha.

I still think it's related to something needed (but not listed) from the stock shock setup. The only part we used was the rubber part that rests between the top of the spring and the top hat section. The TSW directions made it sound like we should be using the setup exactly as assembled, not adding or removing anything.
__________________
<a href=https://www.flickr.com/photos/94346598@N03/with/20975670882/ target=_blank>https://www.flickr.com/photos/943465...h/20975670882/</a>
Reply With Quote
  #8  
Old 08-25-2008, 04:39 PM
Drew Drew is offline
μ
 
Join Date: Dec 2006
Location: Winston-Salem, NC
Posts: 7,157
Default

Quote:
Originally Posted by iDiaz View Post
Hm... the two main things I'd check are the nut that attaches the strut to the bearing in the camber plate and the swaybar end-links.

Ummm.... did we reattach the sway bar end links?

That would also explain why the car felt softer....
__________________
<a href=https://www.flickr.com/photos/94346598@N03/with/20975670882/ target=_blank>https://www.flickr.com/photos/943465...h/20975670882/</a>
Reply With Quote
  #9  
Old 08-25-2008, 04:43 PM
iDiaz's Avatar
iDiaz iDiaz is offline
μ
 
Join Date: Nov 2005
Location: San Marcos, CA
Posts: 15,878
Send a message via AIM to iDiaz
Default

Quote:
Originally Posted by HPUdrew View Post
Ummm.... did we reattach the sway bar end links?

That would also explain why the car felt softer....
That would certainly explain it.

The rattling could be caused by the swaybar knocking against something since it's not attached to the damper.
__________________
Click the image to open in full size.
Reply With Quote
  #10  
Old 08-25-2008, 05:04 PM
simplygriff's Avatar
simplygriff simplygriff is offline
μ
 
Join Date: Nov 2005
Location: Greensboro, North ByGod Carolina
Posts: 14,863
Default

Holy ****... I don't remember doing that one. I know we did the big bolt at the bottom of the shock and we did that second one at the top... I don't remember doing the other one. OMG... If that's it... Wow. Whoops... Wanna come over tonight and help me put it back together in the dark Drew. The lighting behind my house sucks. I think I'm gonna run home in a bit and look and see if that's it.
-G
__________________
phone is ringing . oh my god
Click the image to open in full size.
| The UnDedDub
Reply With Quote
  #11  
Old 08-25-2008, 05:06 PM
dark_S dark_S is offline
Y Rated - 186 mph
 
Join Date: Dec 2006
Location: norfolk, va
Posts: 2,152
Default

or, the stock endlink may have come apart... mine did. had the same one fail two different ways while doing my coils. they're held together with a bunch of press-fit crap that can get knocked loose while you're in there wrenching.
__________________
Click the image to open in full size.
Reply With Quote
  #12  
Old 08-25-2008, 05:15 PM
Drew Drew is offline
μ
 
Join Date: Dec 2006
Location: Winston-Salem, NC
Posts: 7,157
Default

I'm off at 8 tonight, but I'd be glad to come get it fixed if that's it!
__________________
<a href=https://www.flickr.com/photos/94346598@N03/with/20975670882/ target=_blank>https://www.flickr.com/photos/943465...h/20975670882/</a>
Reply With Quote
  #13  
Old 08-25-2008, 05:18 PM
simplygriff's Avatar
simplygriff simplygriff is offline
μ
 
Join Date: Nov 2005
Location: Greensboro, North ByGod Carolina
Posts: 14,863
Default

Thanks man. I'll let you know homie. If that is it, I hope nothing got broken in there.
-G
__________________
phone is ringing . oh my god
Click the image to open in full size.
| The UnDedDub
Reply With Quote
  #14  
Old 08-25-2008, 05:56 PM
justintime's Avatar
justintime justintime is offline
μ
 
Join Date: Feb 2007
Location: hunting man bearpig
Posts: 8,289
Send a message via AIM to justintime Send a message via Yahoo to justintime
Default

is that it? you could just look through your wheel and see it. Ive had two endlinks break on me and create the same problem haha
__________________
Click the image to open in full size.


omgzz
Reply With Quote
  #15  
Old 08-25-2008, 06:18 PM
Slow Paul Slow Paul is offline
μ
 
Join Date: Feb 2006
Location: Upland, CA
Posts: 13,742
Default

Quote:
Originally Posted by simplygriff View Post
Holy ****... I don't remember doing that one. I know we did the big bolt at the bottom of the shock and we did that second one at the top... I don't remember doing the other one. OMG... If that's it... Wow. Whoops... Wanna come over tonight and help me put it back together in the dark Drew. The lighting behind my house sucks. I think I'm gonna run home in a bit and look and see if that's it.
-G
.....I did that too Griff.
__________________
Live Slow, Die Old
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


CURRENT MOON

All times are GMT. The time now is 02:01 AM.
Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
2005 motoring|underground, all rights reserved.